What are the minimum requirements for installing and using my Arlo system? | Range

News Releases

What are the minimum requirements for installing and using my Arlo system?

To install and use your Arlo system, you must have a high-speed Internet connection and the minimum operated system required to use the Arlo Secure app or web portal. You can use the Arlo Secure app or web portal to access video footage from your Arlo cameras.

Connectivity requirements
All Arlo cameras require a high-speed Internet connection, but each Arlo camera uses a different amount of bandwidth. Bandwidth use is measured on a per-camera basis. If you have multiple Arlo cameras on the same network, you can estimate the total bandwidth use of your entire Arlo system by adding the average bandwidth use of each camera.

Your Arlo system requires the following:

  • A high-speed Internet connection to sustain the following average bandwidth use per camera:
    • Arlo Ultra Series: 3 Mbps upload per camera
    • Arlo Pro Series (Pro 3 and newer) and Essential Video Doorbells: 2 Mbps upload per camera
    • All other Arlo cameras: 1 Mbps upload per camera
  • An Internet router with an available Ethernet port if you are using an Arlo SmartHub or Base Station.

Arlo works with the minimum requirements, but the functionality and video quality might be negatively affected. With a lower upstream bandwidth, there is a greater possibility that video quality might be pixelated and unclear. You might also experience a delay in starting a live stream.

Arlo Secure app requirements
To download the mobile app for your Apple or Android device, visit your device’s app store and search for Arlo.

  • Apple devices: For all future product and app enhancement updates, the Arlo app requires iOS version 11 or higher.
  • Android devices: For all future product and app enhancement updates, the Arlo app requires Android version 5.0 or higher.

Arlo web portal requirements

The Arlo web portal requires the following:

  • A computer running macOS or Windows.
  • One of the following web browsers:
    • Chrome on Windows and macOS (latest version)
    • Firefox on Windows and macOS (latest version)
    • Safari on macOS (latest version)
    • Microsoft Edge on Windows (latest version)

Note: If you use the Arlo Secure app on an earlier OS version than these minimum versions, the Arlo Secure app might not function as expected.